How-To : Install and Use Alta Multitool Software

TCMB371

The Silent Assassin
Forum's Sponsor
Likes
1,811
Location
Temecula, CA
I did try changing the Exec line to be "sudo redshift_multitool" but that change makes it so that nothing happens when I use the shortcut. It's not a big deal, I don't mind using the terminal.
If terminal is false, sudo will prompt for a password in terminal but it will be hidden from your view. That's why it seems like nothing happens when using the shortcut. Set Terminal=true and you'll be prompted for your password after double clicking the shortcut.
 

Don Thuren

Well-known member
Likes
77
Location
Bend, Oregon
Thanks guys!

I want to "re-load" my software... My thinking was, seems I need to load different software as when I use the "Loader" function it basically goes through the motions and comes back that everything is already up to date..

Maybe I'm overthinking it though?

Is there a way I can "re-load" the already up-to-date software?
 

TCMB371

The Silent Assassin
Forum's Sponsor
Likes
1,811
Location
Temecula, CA
Thanks guys!

I want to "re-load" my software... My thinking was, seems I need to load different software as when I use the "Loader" function it basically goes through the motions and comes back that everything is already up to date..

Maybe I'm overthinking it though?

Is there a way I can "re-load" the already up-to-date software?
For what purpose would you need to reload the firmware?

You'd have to load a different version first and then reload the original version.
 

Don Thuren

Well-known member
Likes
77
Location
Bend, Oregon
For what purpose would you need to reload the firmware?

You'd have to load a different version first and then reload the original version.

Mark suggested I just check to make sure my whole problem with my bike, isn't a bad firmware install, by reloading it...

Anyone know where to find a different version?
 

Motophyllic

Well-known member
Likes
198
Location
NY
I just purchased an Alta laptop. Could someone please tell me how to unhook the laptop after the software update. Is there any eject button or do I just unplug it after it says update complete?
 

Matt

42 Toasters
Likes
349
Location
Rochester, New York
@TCMB371 would it be possible to get multitool running on a phone using a dongle that goes to USB-C? If so possibly an easy way to keep the display safe would be to tuck the display up in the frame and have dash mode open on multitool on a cell phone mounted somewhere visible like the handlebars. It would also give the rider other useful information like the temperature of the motor and a SOC in %. It would require sorting out a more long term connection to the bike vs the current port.
 

Rashid510

Well-known member
Forum's Sponsor
Likes
738
Location
South San Francisco, CA
Well if you can get ubuntu installed on a cellphone (How to Install Ubuntu on Your Android Phone Using Linux Deploy - Make Tech Easier) and get a USB-C to USB dongle, then it should be able to run MT. MT used to run on laptops of the lenovo variety...which has long gone changed and probably runs on plenty of distros and other systems.

Lots of phones are more powerful now than the Lenovos we used to run, so processing power isnt the issue.
 

Matt

42 Toasters
Likes
349
Location
Rochester, New York
Well if you can get ubuntu installed on a cellphone (How to Install Ubuntu on Your Android Phone Using Linux Deploy - Make Tech Easier) and get a USB-C to USB dongle, then it should be able to run MT. MT used to run on laptops of the lenovo variety...which has long gone changed and probably runs on plenty of distros and other systems.

Lots of phones are more powerful now than the Lenovos we used to run, so processing power isnt the issue.
That's what I was thinking. It would be cool. Maybe I will try it out. I already relocated my display so I have room for it and I have a few old cell phones I could run it on. My main fear would be creating a water tight connection which probably wouldn't be that hard but still a consideration.
 

TCMB371

The Silent Assassin
Forum's Sponsor
Likes
1,811
Location
Temecula, CA
FYI all,

It appears that version dependencies have changed for a few of the packages that are required for multitool, and it requires a bit of linux command line surgery to fix. So, at the moment, following the instructions in the first post will not work. Once I can find free time, i'll try to write up a revised tutorial explaining how to fix it.
 

Cyssko

Active member
Likes
39
Location
earth
Hie everybody
first of all thanks to the creator of this alta controller app and for this post !!!

since a few weeks we are having problems me and my friend ( trying to install multitool )
when in the terminal i cant go further the command -pip
we try on 1 windows laptop and 2 macbook we always got the same problem so we downgrade to python 2 , 2.7 , 3 cause on your video you are not on the latest one so we recreate the same setup as yours but we are still totally stuck ahaha
we officially give up HAHAHA and need help
 

C5tor

Chief Comedic Instigator
Likes
960
Location
San Ramon, CA
FYI all,

It appears that version dependencies have changed for a few of the packages that are required for multitool, and it requires a bit of linux command line surgery to fix. So, at the moment, following the instructions in the first post will not work. Once I can find free time, i'll try to write up a revised tutorial explaining how to fix it.
@TCMB371 - Any luck with the new instructions yet? By the way, the Forum is super grateful that you’d take the time to do this. So thanks in advance.
 

Similar threads